Release Note
ZenTalk

[Replied] [Touchpad] Touchpad & Smart Gesture problems

20565 3
Jump to specific floor
Latest Post
S0S OTHERS Level 1 | All posts
NB Bug Report
System: Windows 10
Battery or AC: AC
Description: Touchpad problems
Model: N580VD
Frequency of Occurrence: Always
Reset OS: No
Screenshot: -
Last edited by S0S on 2018/5/25 18:00

I have been having problems with the touchpad since the first day of buying the laptop. Since the touchpad is such an important part of using a laptop, this makes using the computer very difficult.

Asus Smart Gesture does not make any changes and does not remember any settings. It also has very limited settings considering how many things might need to be configured for the touchpad.

My request for help is for:

1) How I can use Smart Gesture - as it is not working.
2) Fixing the problem of the cursor not moving when starting with a finger on the left edge (large area) and right edge and top edge (smaller area) - meaning maybe, making these areas more sensitive.
3) If there is an option for making the bottom part of the touchpad less sensitive - how to do this.
4) Having the [High] [Medium] [Low] Sensitivity settings working properly - so that taps on the touchpad work after typing ([Most Sensitive] setting works properly]).

Thank you.

Below is some of the History of what I tried before writing here for help.

The pad is often unresponsive. Taps and double taps often worked, but sometimes didn't work.
A Single or double tap had a delay of about half a second before responding.
Dragging a finger across the touchpad sometimes did not move the cursor, specially when dragging from the left side of the touchpad, but also sometimes from the right edge. Also what I believe is called - Edge Swipe - did not work.
The movement of the cursor was often jumpy.

When starting the computer and using the touchpad in the BIOS, the touchpad seemed to work all right (but without shake correction), but not after Windows 10 loaded. So I suspected it was a software problem.

I went to the ASUS website and I installed: Pointing Device Precision Touchpad ver 11.0.17 (Touchpad_ASUS_Win10_64_VER11017.zip )
Under Device Manager/Human InterfaceDevices/ASUS Precision Touchpad/Driver - the Driver version is still 11.0.0.15
This Driver has the date: 16-Feb-17
Checking under Events - there is the error: Device not Migrated
Device HID\ELAN1200&Col02\5&150f7c31&1&0001 was not migrated due to partial or ambiguous match.
Last Device Instance Id: USB\VID_093A&PID_2510\5&350590a7&0&1
Also looking at the details in the CAB file within the new files I downloaded from Asus for installing driver Version 11.0.0.17 shows that the real version is still11.0.0.15 - so I suspected maybe Asus had uploaded the old driver by mistake.
Anyway, installing the driver did not help the mouse problem.

I then downloaded and installed: AsusSmart Gesture ( SmartGesture_WIN10_64_VER405.zip )

I tried to make changes with Asus SmartGesture software, but none of these settings make any changes at all. Also none of them get saved (which really doesn't matter as they don't do anything anyway). Each time I restart Asus SmartGesture, all the settings are default again. I tried uninstalling and reinstalling twice - no difference.

When using Windows 10 Settings / Devices /Touchpad - these make changes - the most important one being "Touchpad Sensitivity."
With the "Most Sensitive"setting, the non responsive cursor problem is better. However on any of the other 3 settings, - "High sensitivity" - "Medium sensitivity" - "Low sensitivity" all three settings do exactly the same thing - and cause a problem as follows:
After typing on the keyboard - "tap"on the touchpad is completely disabled  - until the touchpad is clicked by left or right click made by a hard press down on the touchpad (like clicking a mouse).

Some other details:

System Name    ASUS-VIVOBOOK-P
System Manufacturer    ASUSTeK COMPUTER INC.
System Model    X580VD
System Type    x64-based PC

OS Name    Microsoft Windows 10 Home Single Language
Version    10.0.16299 Build 16299

Hardware Type    HID-compliant mouse
Number of Buttons    0
Status    OK
PNP Device ID    HID\ELAN1200&COL01\5&150F7C31&1&0000
Power Management Supported    No
Double Click Threshold    Not Available
Handedness    Not Available
Driver    c:\windows\system32\drivers\mouhid.sys (10.0.16299.15, 32.00 KB (32,768 bytes), 29-Sep-17 20:41 PM)

Props
S0S OTHERS Level 1 | All posts
Just to clarify, before asking for help, I did the following:

1) Installed ATKPackage Version V1.0.0060 - rebooted
2) Un-installed the Pointing Device Precision Touchpad - rebooted
3) Installed the Pointing Device Precision Touchpad v11.0.17 & Smart Gesture to V4.0.4 Win 10 x64 - rebooted

Windows 10 Home Build 16299 is Version 1709
Props
TWN Moderator | All posts
Hi S0S

I apologize for the inconvenience caused. According to your description, we might suggest you to take your product to our local service center for comprehensive inspection and help you to fix the problem. Sorry for the trouble.

The following is the contact information:
http://www.asus.com/support/Service-Center-All-Countries/

Also you can contact the local service center for help. The following is the contact information:
http://www.asus.com/support/CallUs#

Sorry for the inconvenience.
Props
S0S OTHERS Level 1 | All posts
Last edited by S0S on 2018/6/12 20:07

As suggested elsewhere by the Asus help team, I updated from Windows 10 ver. 1709 to 1803 - and redid all the above. It made no difference apart from taking hours to deal with all the Windows issues & problems that came by upgrading to 1803.

Though my touchpad issue is not resolved (I do not have time to visit the Asus service center), for the time being this is how I made the problem bearable.

The Asus Website has a package for the Touchpad Driver v11.0.17 - but inside the ZIP file is the driver for v11.0.15.
Even 2 weeks after informing ASUS of this mistake, sadly the wrong driver is still being offered for download.

Interestingly, softpedia.com offers both the Asus Touchpad driver v11.0.17 and even a v11.0.19 (but I could not find them on asus.com).
They are both slightly modified versions of driver v11.0.15.
I tried them both (with & without Smart Gesture), but they both have the same problems.

1) I uninstalled Asus Smart Gesture
2) I uninstalled & removed the Asus driver Pointing Device Precision Touchpad v11.0.15 - because the wrong driver is in the zip file on the Asus website
3) I am using the generic Microsoft HID-compliant touch pad driver: 10.0.17134.1 (the default driver when completely removing all Asus touchpad drivers).

This is more stable, but it still has the issue of
A) Sensitivity Settings mentioned in the original post - which makes using the touchpad difficult and slow; and
B) A badly responsive left side of the touchpad (probably because the touchpad is slightly offset from the center of the keyboard, and without Smart Gesture, the HorizontalOffset registry key cannot be set and used.
Props
Advanced mode
You need to login first Login | Register Now

Points policy of this forum

wishes

Archiver|Mobile ver.|

Fast reply Top Return to list
Share by pm