Release Note


[In Process] [Signal/ Connection] SIM1 network data connection not working after system update

111314 50
Jump to specific floor
Latest Post
RebolFan FRA Level 1 | All posts
ZenFone2 Bug Report
Model: -
Firmware/APP Version: LRX22G.WW_Phone-
Frequency of Occurrence: Always
Rooted: No
APP Name: -
Screenshot: -

I've bought recently an ASUS ZenFone2 500KL. Everything was working fine.
I've recently done the following proposed Android 5.0.2 system update : build LRX22G.WW_Phone-
Update process was OK.
But, after update :
+ SIM1 4G/3G/2G network data connection isn't working anymore,
+ Wi-Fi data connection still OK
+ SMS / Phone still OK
+ I have an icon that looks like a key on top of the screen, at the left of the Wi-Fi signal power icon.

Could you provide a solution to make my SIM1 4G/3G/2G network data connection work again, please ?

Thank you in advance.

FRA Level 1 | All posts
i have exactly the same problem.
TWN Moderator | All posts
Dear all,

Are you using dual sim or single sim?

Which sim you set for data service network?

which network type you selected?(settings>more>cellular network>preferred network type) please take a screenshot of it.

taking a screenshot of dual sim card settings as well. thanks~
RebolFan FRA Level 1 | All posts
Last edited by RebolFan on 2015/10/2 20:28

Thank you very much for your reply.
Sorry, I'm right now in a place where there is no Wi-Fi. And, as my 4G/3G network doesn't work anymore after system update, I send you requested information directly in the message :

I will take pictures and post them as soon as I will have Wi-Fi.

I use only one SIM on the 2 available slots : SIM1
SIM1 is set for network data connections

+ settings>more>cellular network>preferred network type = 2G/3G/4G
+ settings>more>cellular network>Data activated = YES
+ dual sim card settings :
    + SIM1 : available -  SIM2 : not installed
    + Name SIM1 : SIM1
       EI Telecom
       Unknown number
   + Preferred SIM card
      Vocal call : always asked
   + Data service network
      SIM1 (Available)

settings>more>cellular network>Network operators>SIM1>Network operators>select automatically => It's very very slow to be registered compared to time before system update.

I hope that it can help.


ROM Level 2 | All posts

I'm experiencing the same issue with this device which was bought two days ago.

The first time the device was booted and configured by using WiFi connection, afterwhich  the android update came via OTA.

When I got out of the WiFi range (outside), I've noticed that no 4G connection is made, then upon digging through the device settings, I have selected the default APN, but nothing happened. I called a friend which sent me an SMS with the APN settings of my network (Telekom), but that didn't work. Next, I have switched my SIM card from slot 1 to slot 2 and after selecting the "Data service network" for SIM 2, in the "Dual SIM card settings" only then the 4G kicked in with an outstanding speed using the default APN settings.

Happy that my mobile data works, I went back home where the device has reconnected automatically to the WiFi, but soon I realized that when the device looses the WiFi connection it won't be able to reconnect back to 4G and no matter what you do it will not connect. The only way to recover from this is by changing the SIM card to a different slot.

Before I was about to right this issue down, I have tried to reproduce once more and came with the following results:

I have changed the SIM card to a differnet slot, the 4G kicked in as expected and then the WiFi was enabled and immediately disabled, 4G is still there, then I have repeated two times by enabling and disabling the WiFi and 4G was still there. I said to myself, OK it seems to work now...

Later, after approximatelly 30 minutes with the WiFi on, I have disabled it, but this time the 4G wasn't there and no matter what I did the mobile data was not present, I was in the same room as where the 4G worked.

What I have did to recover:

- tried factory reset from the recovery menu
- delete cache
- tried reset from the android "backup and reset"
- delete cache
- tried manula update of the ASUS ZenFone 2 Laser(Z00E/Z00ED/Z00EDA/Z00EDB)software Image: V12.8.5.118 for WW SKU only*

All in vaine.

What to note:

The issue will occurs on either SIM 1 or SIM 2
The issue happens mostly when the 4G is disabled automatically, ex: leaving a WiFi coverage.
Only way to recover is to change SIM card to a different slot and select the SIM for mobile data again.

APN settings used:

Nume (Name) : Telekom Romania Mobil

APN: broadband

Tip APN (APN Type): default, supl

I really hope this issue would be fixed because so far I'm in love with this device.

Thank you,
FRA Level 1 | All posts
still waiting for an update too solve the issue. asus, what are you doing ?
ROM Level 2 | All posts
starraider54 posted on 2015/10/3 17:54
still waiting for an update too solve the issue. asus, what are you doing ?

Agreed, but let's have some grade of patience as the issue is fairly recent and they need to investigate this on their own device and then fix the issue and after that, upload and push to OTA the new firmware, which needs software and acceptance testing

Cheers mate
TWN Moderator | All posts
eugen_calin88 posted on 2015/10/3 03:36

I'm experiencing the same issue with this device which was bought two days ago.

Dear  eugen_calin88 ~

I have sent you message. please check your inbox out.

TWN Moderator | All posts
RebolFan posted on 2015/10/3 03:25
Thank you very much for your reply.
Sorry, I'm right now in a place where there is no Wi-Fi. And, as ...

Hi RebolFan~

Please check for me if you select network type 2g/3g or 3g,  and see if that works?

also please put your sim card into slot 2 and check how it works.

ROM Level 2 | All posts
Last edited by eugen_calin88 on 2015/10/6 03:03

Hello Asus,

Today the issue occurred again and I decided to help you track down with a logcat.

In the attached logcat I did the following steps:

1. Disabled the WiFi connect (Power ranjer)
2. Waited for the mobile data to connect
--------- Mobile data has not connected---------
3. Disabled/Enabled mobile data and waited to appear
4. Launched default browser to see if it will trigger the mobile data
5. Enabled/Disabled again the WiFi

I would like to note that I am in the same room were my provider (Telekom) has coverage for 4G/3G/2G and the phone did connect with APN settings, which strangely worked during the day.


logcat of the mobile data

54.27 KB, Downloads: 1448

Advanced mode
You need to login first Login | Register Now

Points policy of this forum


Archiver|Mobile ver.|

Fast reply Top Return to list
Share by pm