Release Note
ZenTalk

[Replied] rog keyboard firmware update tool v 2.1.8  

7574 165
Jump to specific floor
Latest Post
CYP Level 1 | All posts
Dear all,
Happy New Year to all of you! I am new to ASUS Community and new to this forum. I just bought the SCAR III G531GW and MyASUS application indicates an update of ROG KB Firmware Update tool V2.2.2. When i select the update i receive the following message: "There are no available keyboard firmware in the update folder." Please see the attachment!! I don't know what else to do. Can any one help me please?

Thank you ind advance!
Props
OTHERS Level 1 | All posts
Happy New Year to all!
Got a new G731GW for a few days and got the same keyboard-firmware-update-issue like a lot (if not all) other people here (even with version 2.2.2) - and found a workaround or better saying dirty hotfix.
WARNING 1 TO DO SO IS NOT RECOMENDED BY ME & I WILL NOT TAKE ANY RESPONSIBILITY IN THE EVENT OF FAILURE! DO IT @ YOUR OWN RISK!
Modell G731GW (but should work with G531... & G731... ...GD; ...GT; ...GU; ...GV & ...GW)



That's what i did:
  • it helps to clear the temp-folder (user\appdata\local\temp) before trying this way
  • i downloaded the keyboard firmware manually (v2.2.2) & tried to install it - got same error message like in posting #8 of this thread
  • now & directly (before closing the error-message-cmd-window) i went to my temp-folder in the explorer
  • & found a new *.tmp sub with very interesting ingredients - the update-script, some tools for flashing and even the firmware files. the files are there (but maybe wrong adressed in script). there's a @ROGKBFWUpdateTool
    sub which contains the flashing tool (same name) and inside another @FW sub with all possible firmware-files for the above listed modells.
  • the error messages here said that the firmware-files are missing in executable-folder so i did so - grabbed the later file for my modell and moved it 1 folder higher to the flashing-tool - and started it
  • flashing went fine & as described for the original asus-tool (better cause this works and has a gui)
  • after all i got the actual firmware and no useless update-warning in asus-tools
  • WARNING 2 i had to reinstall aura-creator to find my kb
  • WARNING 3 even the new firmware does not push the auro creator to work properly - no improvement in my case
If this posting inspired you to do something on your laptop or just to walk a while through a forrest or maybe go to eat something - in every case: have fun!



Props
CYP Level 1 | All posts
SpeedBob posted on 2020/1/10 02:59
Happy New Year to all!
Got a new G731GW for a few days and got the same keyboard-firmware-update-iss ...

Bob,
Can you explain it again somehow privately with illustrations?? I can chat at Viber/Whatsapp/FB messenger whatever you prefer!!
Props
UKR Level 1 | All posts
Last edited by dormivs on 2020/1/10 22:55
wamid posted on 2019/11/21 15:15
Hi! I also had a similar situation with ROG Keyboard Firmware Update tool v 2.2.2. After updating th ...

Bro, you made my day! Have been struggling with that stuff few evenings after work.

Dear(not) Asus,
If you're assuming that throwing to a download page random amount of zips with .bat, .exe files without any instructions inside(in most cases) and even without vendor signature(which makes any antivirus scream like a b*tch) is a good idea - I guess not. Why don't just create a simple package installer with simple algo which driver install first, which next, etc? Instead of this you're guys writing "manuals" which may be understood mostly by technical people. And what about another guys\girls who bought laptop for 1500$+ price?

Getting back to that freaky v2.2.2 update - the package while installation cracked up the Armory Crate for me, fortunately it was ony one problem. But, before you're releasing somethig, could you please make your QA try to.... unpack it maybe? And, please, if you'd love to screw your reputation up soo much by testing bad updates on users, add a feature for MyAsus to roll back the updates for your utils.

With no regards,
Valentyn.
Props
BGD Level 1 | All posts
Last edited by home139434 on 2020/1/11 19:31

Hello, I just got my Rog G531GT & after installing Keyboard firmware from my asus app the keyboard is totally dead & i can't do a single thing, what is the solution for thia
Props
BGD Level 1 | All posts
is there any solution for this problem? i can't use my laptop 
Props
Advanced mode
You need to login first Login | Register Now

Points policy of this forum

Posts3 ZenCredit0 Points21 best answer0

wishes

Archiver|Mobile ver.|

Fast reply Top Return to list
Share by pm