Release Note


[Replied] [System] Asus Zenfone 5 Cannot Connect USB Storage to PC

147998 65
Jump to specific floor
Latest Post
hmehta008 IND Level 1 | All posts
ASUS 5 Bug Report
Model: ZC600KL
Firmware/APP Version: LRX21V.ASUS_T00J_WW_user_3.23.40.52_20150522_91
Frequency of Occurrence: Not Working
Rooted: Yes
APP Name: USB Pairing
Screenshot: -
I am having Asus Zenfone 5 [India] A501CG
Baseband Version: 1515_1.4.66.0_0422
Build No. : LRX21V.ASUS_T00J_WW_user_3.23.40.52_20150522_91

I Cannot connect the phone to PC via USB Cable

Tried all of your USB ports of PC
Turned on the MTP option
PC Link Installed on Device and PC both
checked 'usb debugging' option
USB Ports working Fine with pendrive
also Phone Charges when connected to PC

just that it doesnt detect any device when connected to pc
"used to work well after the lollipop upgrade too"
till i once used OTG cable and after usage i removed USB Pendrive without safely Unmount OTG Device option

Unable to Connect on Windows 8.1 and Windows 10 Too

Please help

IND Dr. Zen(IN) | All posts
#1 Make sure that, you have the right drivers

The probability of this issue will be less if you are using a windows PC. Bcause almost all required drivers will be installed by windows once a  new hardware is connected to it. You know, every hardware need some software part to install for the smooth working. We call it as drivers.. Make sure that, your PC automatically installs it. If your computer didn’t install it automatically, then you can manually download and install it directly from the ASUS website.

Download and install ASUS USB drivers for Windows

#2 Try all of your USB ports

I don’t know the technical reason behind this. I am writing this because, this issue had personally faced by me. I have windows 7 installed on my PC and my USB port behind the CPU won’t detect my zenfone. There is no issue with charging. The issue is only with the data transfer. But the USB port in-front of my CPU detects as well as charges my zenfone. So try changing the ports to all possible extend. If anyone knows why this happen, please comment below. It will be an add-on tip for me.

#3 Check whether you have turned on the MTP option

This is yet another option to check out. And this is the answer for the Balaji’s email just above. Many people accidentally un tick the MTP option when they connect mobile to PC via a USB. Then to activate it again, there is no direct USB options in your Zenfone. You may get messed up with this issue. Don’t worry here we have the solution. The USB options are available in your Settings>Storage. Follow the steps through the screenshot.
◦Go to Settings page of your zenfone.


◦Now select the storage option


◦There you can see a USB symbol on the top right corner. You need to click on that and put a tick mark against the MTP option. Check the below screenshot for clear understanding.


◦Once the MTP option is selected, your PC starts detecting your Zenfone 5 or zenfone whatever it is.

IND Dr. Zen(IN) | All posts
1.connect your phone to pc via usb cable
2.go to device manager and there you will see android device with yellow sign
right click android device and click on update driver on browse my computer for drivers
4.then click on android device and click next, then select android composite adb interface and click next, will install driver then your problem will be solved
IDN Level 4 | All posts
Try Intel Android USB Driver here
The same problem occure for me

yesterday i remove my OTG without UNMOUNTING

after that today

i connenct my phone with pc
MTP checked
USB debugging checked
Driver Updated

but MTP not detected
and OTG not working

pls put a solution for me
IND Dr. Zen(IN) | All posts
sakthikannan777 posted on 2015/8/17 22:17
The same problem occure for me

yesterday i remove my OTG without UNMOUNTING

clear cache of file manager app and wipe partition cache.
Should do it.
how to clear wipe cache partition cash
pls tell steps
after factory reset also this problem occure

pls give solution for this
hmehta008 IND Level 1 | All posts
Tried every thing... Fed up of this problem.
none of the solution is working for me

Tried each and every above mention Solutions
Not working guys!!!!!

When i connect my Asus Phone to PC nothing shows up on my PC
hmehta008 IND Level 1 | All posts
debopriyobasu posted on 2015/8/18 19:52
clear cache of file manager app and wipe partition cache.
Should do it.

Friend Please show steps to do this procedure
with pics please.

Advanced mode
You need to login first Login | Register Now

Points policy of this forum


Archiver|Mobile ver.|

Fast reply Top Return to list
Share by pm