Release Note
ZenTalk


[Resolved] [System] Manual system update from MM to O failed. Starting FW version is too old?

1030 3
Jump to specific floor
Latest Post
zenmp73 OTHERS Level 1 | All posts
ZenFone 3 Bug Report
Model: ZS570KL(Deluxe)
RAM: 6GB
Firmware/App Version: TIM_4.11.40.1217_20161014
Location: -
Frequency of Occurrence: always
Rooted: No
App Name: -
Screenshot: -
Description: system update failed (3) - unknown error while performing manual update from MM TIM_4.11.40.1217_20161014 to Oreo with downloaded SKU UL-Z016-TIM-15.0210.1807.67-user
Last edited by zenmp73 on 2019/2/20 17:37

Hi everyone,
got a brand new ZS570KL with TIM SKU. Android version onboard is Marshmallow (TIM_4.11.40.1217_20161014). I dowloaded from ASUS website latest available FW for the TIM SKU based on Oreo (UL-Z016-TIM-15.0210.1807.67-user). Followed instructions for manual update but after some minutes I got a FW update error with dead Android picture and red triangle on it. There are no log lines that explain the cause of the error, just the picture is shown.
After rebooting I get an error poput saying:
System update failed. (3) Unknown error. System restored to previous configuration.

I then did another attempt performing manual update by placing the same update file on SDCard and using the Recovery mode. The error message I got was: The version is unmatched. Error in /sideload/package.zip (Status 7).
I got the same error trying with a different update file (see attached screenshot).

I assume the cause is that the starting version for the update is too old, i.e. it is not allowed to update directly from Marshmallow to Oreo.
My questions are:
- how can I know which is the minimum FW version I need to have installed beforer updating to a certain target version? The release notes contain no such information
- which update steps should I perform for updating to Oreo from Marshmallow? Only available TIM SKUs from ASUS website are:
UL-Z016-TIM-5.14.44.2193-user (Nougat)
UL-Z016-TIM-15.0210.1805.54-user (Oreo)
UL-Z016-TIM-15.0210.1807.67-user (Oreo latest)




Thanks for the help


recovery.jpg
Props
TWN Moderator | All posts
Last edited by Selena_ASUS on 2019/2/22 17:45

Hi zenmp73

Please try to download the firmware form official website and update From M>N>O,
UL-Z016-TIM-5.14.44.2193-user (Nougat)
UL-Z016-TIM-15.0210.1807.67-user (Oreo)

If it still failed, please providen SN number in box
Thank you
Props
zenmp73 OTHERS Level 1 | All posts
Hi Selena,
got your advice, PROBLEM SOLVED, below a recap of the solution:

- Factory version on phone: TIM_4.11.40.1217_20161014 (Marshmallow)
- No OTA update notification
- Downloaded UL-Z016-TIM-5.14.44.2193-user (Nougat) from ASUS website and installed manually from recovery mode
- Phone successfully updated to TIM-5.14.44.2193 (Nougat)
- Immediately got a notification for OTA update available
- Accepted OTA update
- Phone successfully updated to TIM-15.0210.1807.67 (latest Oreo available)
- Phone works perfectly, no battery drain, no autofocus issues whatsoever

This is a great news for all Zenfone 3 Deluxe users in Italy where the device is sold by TIM carrier as an exclusive. Many people complained they were stuck to Marshmallow, this is the way to solve!

Thanks a lot!
Props
TWN Moderator | All posts
zenmp73 posted on 2019/2/26 00:15
Hi Selena,
got your advice, PROBLEM SOLVED, below a recap of the solution:

Hi zenmp73

I'm glad that your issue has been resolved
and thank you for sharing your solution with the rest of the forum members

Thanks and have a nice day.
Props
Advanced mode
You need to login first Login | Register Now

Points policy of this forum

wishes

Archiver|Mobile ver.|

Fast reply Top Return to list
Share by pm