Release Note
ZenTalk


[More Information Needed] [Signal/ Connection] 4g not working

653 2
Jump to specific floor
Latest Post
yussimov KAZ Level 1 | All posts
ZenFone 3 Bug Report
Model: ZE520KL
RAM: 3GB
Firmware/App Version: WW_14.2020.1711.83_20171220
Location: Kazakhstan
Frequency of Occurrence: -
Rooted: Yes
App Name: -
Screenshot: -
Description: no 4g connection. Works only 3g
Hello everyone,
I have a problem with my 4g connection.

My zenfone 3 can't use 4g, only 2g and 3g.
I tried everything that i found here, but nothing helped.

I tried to upgrade firmware, factory reset, change operators, change all my sim cards and still i haven't 4g connection.

I tried to lock only LTE, and then i just lost data usage.

Please help!


Props
GBR Level 4 | All posts
Had your phone ever connect to 4G? If not, it could be due to your phone not supporting the 4G band used by your network.

https://www.asus.com/Phone/ZenFone-3-ZE552KL/specifications/
Look under "Network Standards".

There are so many versions of ZF3 and no way of confirming which version you have so it is almost impossible to confirm which bands the phone you have supports.
Props
TWN Moderator | All posts
Hi yussimov,

Have you ever connected to 4G?
Does the same sim card get the 4G connection at the same place on the other phone?

Please check with your mobile operator for the 4G coverage at your place.

Thank you
Props
Advanced mode
You need to login first Login | Register Now

Points policy of this forum

wishes

Archiver|Mobile ver.|

Fast reply Top Return to list
Share by pm