Release Note
ZenTalk


[Replied] Steps to come back to stock rom from custom recovery

8814 8
Jump to specific floor
Latest Post
ZenFone2 Bug Report
Model: ZD551KL
RAM: 3G
Firmware/APP Version: na
Frequency of Occurrence: na
Rooted: Yes
APP Name: -
Screenshot: -
Last edited by varungenius2008 on 2017/7/14 04:39

I installed the Lineage os to get the volte function,but i was not happy with the Lineage os as the battery backup up was really bad on it,so i decided to come back to the stock rom

I tried searching a lot "how to come back to stock recovery from custom recovery


As Volte is working on the stoc rom i decided to come back to stock rom,as the Lineage was having a lot of bugs,i tried searching a lot but i didn't found any good thread,so i am posting this,so that it can be hlpful for those who wants to come back to the stock rom

Please do it at your own risk,i will not be held responsible if something happens to your phone

Guide to install stock recovery that will replace the Twrp recovery:-

Download the stock recovery.img file from the link below,download recovery file from WW_21.40.0.1999 folder


https://mega.nz/#F!Ao1RjT7D!hQ5x60r02WveB9-Hl32B4g

Rename the file as recovery.img,place it in the folder

Download the stock rom from Asus website from the link below,download Version WW-21.40.0.1999 (2017/01/10),as the recovery file and stock file shold be same,use the link below

https://www.asus.com/Phone/ZenFone_Selfie_ZD551KL/HelpDesk_Download/

Place the file in internal storage and external storage as well to be on the safer side

Enable the usb debugging,go to about phone,keep tapping on build number repetedly,since you get the prompt"you are a developer:,go back in settings and enable the usb debugging

Now opnn the folder where you have placed the recovery.img file,press shift + right click on the empty space in the folder,select the option "open command window here"

You will get the cmd window

Type adb devices to check if your device is connected properly or not (if it is connected properly, you will get the serial number of the device)

Connect your device to the PC. And type the following into the command window
adb reboot bootloader   (press enter)

Your device will boot in fastboot mode. Now we need to flash the stock recovery

Type the below command and press enter
fastboot flash recovery recovery.img

Once recovery is successful type the command below to reboot the device
fastboot reboot

Your phone will reboot now,You may use the below link for detailed instructions


http://www.theandroidsoul.com/remove-twrp-recovery-restore-stock-recovery/

Now we need to flash the rom

Turn off the phone,press vol down + power key togeather to enter the recovery mode, you will be getting the stock recovery now

Select the option "Install from sd card" select the zip file you have downloaded from the Asus website,it will start installing the rom,this process will take around 10+15 minutes,so be patient,once its installed,reboot the phone

My phone got stuck on rebooting after that,so i went back to the recovery mode and did a factory reset and deleted the chace and installed the zip file once again from external sd card

And luckily after restarting i got the stock rom working perfctly fine

Now we need to install the latest version to get the volte function enabled

Simply download the latest zip file Version WW-21.40.0.2156 from Asus website

Place it in internal sd card,it will automatically detect the update and you will get the notification,select install the update

It will be installed successfully and you can enjoy the volte on stock rom

If you have any problem,please ask the question,i will try to help you out,i will keep checking this post for next 5-10 days








Props
IND Level 2 | All posts
I have a ze551ml Zenfone 2.
I tried to install lineage os and unlocked bootloader, rooted my phone and installed TWRP 2.9.
But when I try to install lineage os, or for the fact any os, I am getting the error
"Error executing updater binary"


Please help me have any os working on it.
With regards
Props
IND Moderator | All posts
Hi Varun,

Thank You for this information.
Props
hrsagar28 posted on 2017/7/14 06:54
I have a ze551ml Zenfone 2.
I tried to install lineage os and unlocked bootloader, rooted my phone a ...

Are you able to boot your phone?
If not do a advance wipe y going to the twrp recovery,delete everything excluding external storage,and then try reinstalling the reo

I would personally suggest you to stay on the official stock rom,as Lineage os not good as compared to the stock rom
Props
IND Level 2 | All posts
Actually I even deleted the stock is while installing lineage os and now stuck with no os left.
Even stock is is not installing as I get the error "executing updater binary"
Props
Have you tried doing a advance wipe from twrp recovery,just check everything excluding external memory card and do a advance wipe,
Then download the lineage os and try to flash that
You cannot install the stock rom frm Twrp,we need to be in the stock recovery in order to do that,so first we have to install the lineage os
Props
IND Level 2 | All posts
Yes I tried doing advance wipe but didn't help. 
The actual fact is that I was on lollipop bootloader and not marshmallow bootloader, which may be I suspect the reason for lineage os not installing.


So now, should I go back to stock recovery and try installing stock marshmallow os?
Props
IND Level 2 | All posts
Last edited by hrsagar28 on 2017/7/17 07:09

Thanks in advance for your efforts.
Props
Yes, try diwnloading the recovery.img file and see if your device is getting detected or not
Props
Advanced mode
You need to login first Login | Register Now

Points policy of this forum

wishes

Archiver|Mobile ver.|

Fast reply Top Return to list
Share by pm