Release Note
ZenTalk


[More Information Needed] [System] File Transfer/Mass Storage mode not working well under Win10

2524 6
Jump to specific floor
Latest Post
Chumbo FRB Level 1 | All posts
ZenFone2 Bug Report
Model: ZE500KL
RAM: 2G
Firmware/APP Version: MMB29P.WW_Phone-13.1010.1612.53-20170202
Frequency of Occurrence: 1,0
Rooted: Yes
APP Name: -
Screenshot: -
From the 1st day I started using my phone, it never really connected well to a PC through USB for transfering files. In fact, as I remember, it didn't connect at all in the beginning! I had to google a long time to finally find a a driver file I was supposed drop in some folder in Windows and that has sort of got it working...but not really!.
By default, it always  connects in 'Charging' mode (already that is annoying). I then need to select 'File transfers' mode which rarely works the first time. So I then change it again to 'Charging' and back again to 'File transfer' and maybe then it would work! If not, I have to go for another round of changing connection modes!?

This can't be normal, I can't imagine everybody is putting up with this, right?? So is my phone defective or is there a some fix for this?
Thanks,


Props
Hello kennethmoffett
What driver did you install? Did you get it from Google or someplace else?
The USB mode should remember the last configuration and stay on it next time
Have you tried changing a cable or a USB slot?
Does it happen to other computers as well?
Thank you
Props
Chumbo FRB Level 1 | All posts
Last edited by kennethmoffett on 2017/6/13 21:24

I don't remember where I got that driver. Just forget I even said that. What's important is that it never worked out of the box, that was just a 'hack', a solution I found somewhere by googling, otherwise I was unable to connect to a PC!

I just tried on a Win10 tablet, this is what happened:
- I connect the phone with an other USB cable and Win10 detects a new device and attempts to install it. However the progress bar stays stuck at +-10% so I then go to the phone and switch from 'Charging' to 'File Transfer' mode and that makes my phone appear in Windows. I then disconnect it to see if it will reconnect properly....I've now tried 3, 4 times, it hasn't reconnected at all! It no longer shows up in Windows!

I tried on the PC with a new cable on a different port...same thing. Well, not the same as with the tablet but same problem as initially described in my original post: it will connect after a few rounds of changing modes between 'Charging' and 'File Transfer'.
But in all cases, it always FIRST connects as 'Charging'.
Props
ROM Level 2 | All posts
Last edited by andreiursan on 2017/6/14 13:42

Hello. Is you Windows 10 up to date ? Are you having the latest and original drivers(from the factory website) for USB ports ?
Another thought is to go to Device manager, with the phone connected, and uninstall the related devices. Afterwards disconnect the phone and download and install this drivers(from Asus website)  : Usb drivers . After that, restart your PC or tablet .After restart, connect the phone and let's hope Windows will search for drivers on PC/tablet first.

Props
Chumbo FRB Level 1 | All posts
Last edited by Chumbo on 2017/6/14 17:53

I did what you wrote, it unfortunately didn't change much of anything. The problem is more or less the same.
But what I would like to first understand is, if my Zenfone was working properly, how would it behave? Would I still have to have a separate USB stick with a driver on it for every PC I connect to?!?

But back to my problem...what next?? Is it defective? Should I turn it in for repair while it's still under warranty? Or are there any other solutions to try?

BTW, there was no Win 10 specific driver in your link so I used the most update, the one for Win 8.1.
Props
Chumbo FRB Level 1 | All posts
So...that's it? The end of Asus Support!? What do I do next? Just at least tell me if I should send it back for repairs or if there is something else I can try?
Props
Chumbo posted on 2017/6/15 21:47
So...that's it? The end of Asus Support!? What do I do next? Just at least tell me if I should send  ...

Hello Chumbo
I'm sorry for the late reply
I've tested the ZE500KL with the latest firmware installed
it connects to a Win10 laptop with no problem
I would suggest to send the phone to your nearest repair center for check ups
http://www.asus.com/support/Service-Center-All-Countries/
Thank you
Props
Advanced mode
You need to login first Login | Register Now

Points policy of this forum

wishes

Archiver|Mobile ver.|

Fast reply Top Return to list
Share by pm